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1. Getting Started
.....····;>SOZOILfafWind·],i.···g."." , ,. , ' .....• i.·· •.•.'i.,.·

COZOIL for Windows requires an IBM-compatible 586 or better PC, with 16 MB RAM, 30 MB
free disk space on the hard drive, a VGA color monitor, and Microsoft-compatible mouse,
running Windows 95.

To install:

1. Insert the installation CD-ROM.

2. Choose Run from the Start menu, and type d:setup in the Windows dialog box.

3. Follow the installation instructions on the screen.

4. When installation is complete, you will have a new program group labeled
COZOIL for Windows, with an icon for the COZOIL model system. Close this
COZOIL for Windows program group, and use the Reboot facility before
running the program.

To remove COZOIL from a Windows 95 platform:

1. Delete the entire COZOIL directory.

2. Remove the COZOIL program group.

This manual covers the following topics:

• Installing COZOIL (Chapter 1)
• An overview of COZOIL and its components (Chapter 2)
• How to specify the environmental data sets required by the models (Chapter 3)
• Running the spill model and displaying model results (chapter 4)
• COZOIL auxiliary tools (chapter 5)
• The COZOIL database (chapter 6)
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2. The Basics

COZOIL is an oil spill model system used to predict the movement and fate of oil spilled in the
marine environment.

The COZOIL model system is comprised of several integrated components. The spill model
itself predicts the movement of oil on the water surface and the distribution of oil in the
environment (evaporated, in the water column, on the shoreline). For these calculations the
spill model relies on environmental data such as wind and currents, physical data such as the
proximity of shorelines, and chemical data that defines the type of oil. Each of these types of
data can be input and edited using the appropriate COZOIL component.

Although land and water is represented by polygons on the screen, the model actually uses a
gridded representation of this land and water boundary to determine:
• Whether oil is on land or water
• What is the shoreline type of the land grid cell?
• What is the depth of the water cell?

The grid uses the COZOIL shoreline database to determine the shore type. To display these
shore segments, check the Display Shore Types menu on under the Data menu.

The COZOIL application is specific to a particular geographic location. All data, spill scenarios,
and model output are stored within this location. The location consists of an area defined by its
outermost longitude/latitude coordinates. The location is given a name and contains a base
map depicting land and water. The name of the active location is displayed at the top of the
map screen.

COZOIL has three locations. To move
between locations, select Geographic
Location from the File menu. The
available locations will be listed. Click
on the desired location to make it active,
and then click on OK.I: [\ \ASA·l \SYS3]

1271:\
127 cozoilGOA I ••

LJ arctic
LJ bering
LJ goa
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Spill Scenarios are the means of organizing model data and parameters into unique collections.
A spill scenario in COZOIL is a collection of information which defines a model simulation. This
information includes a definition of the spill and the environmental data files used in the
simulation, saved under a unique scenario name. Typically a scenario specifies the land-water
grid, wind file and currents file used in the scenario; and the particulars of the spill itself (date,
location, oil type and amount released). Any of the data files which comprise a scenario may
belong to a single scenario, or multiple scenarios.

Wind
Data

Spill Information
Spill Location
Spill Amount
etc.

Current
Data

Land-Water
Grid

SCENARIO

Before a model simulation, a scenario is only the set of forms inputs defining the input data.
After the execution of a model simulation, a scenario also has model output associated, which
may be displayed. Thus the term "scenario" is used to describe both the inputs and the outputs
of a model simulation.

In COZOIL there is always one active scenario. The active scenario name is displayed on the
tool bar, and the components of the scenario can be viewed in the map window.

There are several options available under the File menu for handling scenarios.

• New Scenario is used to specify a new spill scenario. For this option, specify the scenario
name, and select the land-water and currents grids. Spill simulation parameters will be set
under the Model/Run Model menu.

• Open Scenario is used to open a previously defined scenario and the results of the spill
simulation. The scenario selected becomes the active scenario. Its name is displayed on
the toolbar and the simulation output can be displayed in the map window.

• Save Scenario is used to save the active scenario. If any editing has been performed on
the currents or land-water grid.

• Save Scenario As is used to save the active scenario under a different name.

• Edit Scenario is used to change the land-water and currents grids associated with the
active scenario. Changes made using Edit Scenario are automatically saved.

2-2
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The RESET button is availalble when a scenario is
being opened and a model simulation has been run
previously for this scenario. It will reset all of the
scenario parameters back to the state that was used
when the model simulation was run. This is useful if, for
instance, you edit the scenario and change the active
grid or edit some parameters without running the model.
The reset button will then set the scenario information
back to exactly the parameters that were used to
produce the model simulations.

The standard COZOIL screen consists of three major sections.

• Below the menu bar is the COZOIL toolbar. The toolbar contains buttons for various GIS
and map functions, and displays the name of the active spill scenario. The toolbar includes
buttons to control the display of the active scenario.

Impact Probability

Keys which are not active are "grayed out". The toolbar options are described briefly below.

To zoom out to the previous zoom level.

To measure distances and areas.

2-3

• At the top is the standard menu bar:

Or

Map Buttons

Ii
m
~

••
[kI

To interrogate GIS objects.

To create a zoom window.

To add/edit current vectors .

To edit land-water grid cells.



ir!l

Q

n
D
r
o

('""

n
n
n
Q
Q

n
o

~ o
Q

Q

~

n

Oil Spill Animation Buttons

l'iiil•....•.•....•.•••.....•.......•.•...I.
WfiiIJDj

~..........•....".....

~

[tit

Rewinds the spill simulation to the start.

Displays the spill simulation in reverse.

Displays the spill simulation one timestep at a time.

Stops the display of the spill simulation.

Displays the spill simulation.

Displays the time in the simulation being shown. Click on this
box to select a particular time.

/96 08: 00: 00
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Several Zoom options are available to change the scale of the
map display. Using these options the scale of the map can be
increased or decreased, and the center of the map display can
be shifted. All these options are available under the Zoom
menu.

!;.reate Zoom Window Ctrl+W
Zoom !n Previous Ctrl+1
Zoom Qut Previous Ctrl+O
!!nZoom All Ctrl+U
Pan Point to Point

To zoom in on an area of the map display:

1. Select Create Zoom Window from the Zoom menu - OR - click on the Create Zoom
Window icon m on the COZOIL tool bar.

2. Move the mouse cross-hair to one corner of the area to zoom into.

3. Hold down the mouse button and drag a box around the area to zoom into.

4. Release the mouse button, and the new zoom window will be created.

To return to a previous zoom window at a larger scale:

1. Select Zoom In Previous from the Zoom menu.

2. Each time you select Zoom In Previous, the zoom window created at a larger scale
than the current window will be displayed.

To return to a previous zoom window at a smaller scale:

1. Select Zoom Out Previous from the Zoom menu - OR - click on the Zoom Out icon on
the COZOIL toolbar.

2. Each time you select Zoom Out Previous or click the Zoom Out icon, the zoom window
created at a smaller scale than the current window will be displayed.

To return to the original map scale:

1. Select Unzoom All from the Zoom menu.

To re-orient the zoom window:

1. Select Pan Point to Point from the Zoom menu.

2. Click the mouse cross-hair on the map to set a reference point to move. Then move the
cross-hair to a new point on the screen where you want the previous point to be
displayed, and click. For example, if an island appears at the lower left of the map
display and you want to re-orient the display so the island is in the center, click on the
island, move the cross-hair to the center of the display and click again. The window will
be redrawn at the same scale with the island in the center.
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Several options are available to adjust the
COZOIL map display. These options
include the colors and measurement units
used, and the map projection.

Most of the map settings that can be
changed are accessed through the
Display Settings option of the File menu.
This option brings up a form to:

• select the colors used for land, water,
current vectors, and the longitude/latitude
grid. To select colors, click on the color
box to bring up a color menu.

• Specify whether a longitude/latitude
grid is shown on the map. Toggle the
field between Yes and No.

• Specify the units longitude and latitude are presented in. Toggle the field between decimal
degrees (00.00), degrees and decimal minutes (DO MM.MM), and degrees-minutes-
seconds (DO MM SS).

• Specify the units current vectors are presented in. Toggle the field between mm/s, cm/s,
mis, and knots.

• Specify whether a distance scale is displayed on the map. Toggle the field between Yes
and No.

• Specify whether to use No Projection or a Mercator Projection for the map.

To get the distance between two points, select the Distance Measure icon on the tool bar. Click
on the point from which to measure distance. This sets one end of the measurement line. As
you move the cursor around, the distance between the set point and the cursor's position is
given at the lower left of the map. Clicking again with the left button will start another
measurement line segment. The total cumulative distance of all the line segments is displayed
on the status bar. Click with the right mouse button to close the polygon and get the area of the
polygon. Hit escape to exit the distance measurement mode.

2-6
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3. Specifying Environmental Data

In this chapter the steps required to create the environmental data files used by the spill models
in COZOIL are described. Subsequent chapters present the individual models and describe
how to specify the scenario, run the models with the defined inputs, and display the results of
these model simulations.

The spill models require several types of input data.

Land-Water
Grid

Current
Data

Wind
Data

Spill Information
Spill Location
Spill Amount
etc.

SCENARIO

See the appropriate section later in this chapter for complete information on how to specify
each type of data.

1. A land-water grid. The land-water grid covers all or some part of the base map in the
active location. The grid should cover the spill site and the surrounding area of interest
(oil which moves outside the grid is not tracked). The land-water grid is used by the
models to determine which areas are land and which are water and to determine what
type of shoreline (ie. Sandy beach, Rocky shore, etc.) is along a coastline.

2. Wind time series. The wind time series provides the model with wind data measured
and/or forecast in the vicinity of the spill. The wind data consists of wind speed and
direction for a period covering the spill simulation.

3. A current field. Current data is provided with COZOIL and is based on the the COZOIL
database values. See the COZOIL Database chapter for more details.

4. The oil characteristics. COZOIL contains a library defining the characteristics of
several standard oil types. If desired, additional oils can be added to this database, or
the characteristics of the existing oils can be changed.

5. The spill scenario. The spill scenario contains the data that uniquely describe the
inputs to a particular simulation to be run. It includes the spill location, spill date/time,
type of oil, amount spilled and length of release, and specifies the land-water grid, wind
data, and currents used in the simulation. Spill scenarios are saved with a user-defined
name and the model results are given the same name (with a different extension).
Defining the spill scenario is described in Chapter 4.

3-1
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In order to run a spill simulation, you must have a land-water grid to define what is land, what is
water, and what are the characteristics of the shoreline. The grid is a square mesh of individual
cells covering the area of interest. Each cell in the land-water grid is classified as either land,
water, or coastal. Each coastal cell has a code that indicates what shoreline type is dominant in
the grid cell. Each water cell has a value that indicates the depth of the water in that cell.
Each cell is the same size (in degrees), although they may not appear that way on the screen
based on the latitude and the map projection.
The maximum grid size is 250 by 250 cells.

Displaying a Land-Water Grid

The name of the selected land-water grid is displayed in the data tool bar (Use Edit Scenario in
the File menu to change the selected land-water grid). Select Cells to display the grid cells and
check the display box to the left on.

Creating a Land-Water Grid

The land-water grid is created by the following sequence of steps:

1. Select Create Grid from the Data menu.

2. While holding down the left mouse button,
drag a box on the map defining the area to
be covered by the grid.

3. Enter a name for the grid file and the number
of grid cells in the X (east-west) and Y
(north-south) directions. There can be a
maximum of 250 grid cells in each direction;
the minimum is 1 cell.

4. Click OK to save the grid.

A land-water grid will automatically be created for the area selected. When the process is
complete, you may automatically include this new grid as part of your Active Scenario.
See the previous section, Displaying a Land Water Grid or how the display this new grid.

Examine your newly created grid closely to be sure the delineation of land and water is
appropriate for your model simulation. As an example, make certain the cell size is small
enough to resolve narrow inlets as water cells and that small islands are flagged as land. If the
grid is not appropriate, remake it using a larger or smaller cell size or edit the grid to change the
classification of individual cells.

3-2
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Shoreline types will also be assigned to each coastal cell from the COZOIL database of shore
types. An interpolation method is used to determine the closest shoreline segment to each
coastal cell and the type of that segment is assigned to the cell. To display these actual shore
segments, check the Display Shore Types menu on under the Data menu.
Depth data is also interpolated from the COZOIL database.

Editing a Land-Water Grid

Any existing grid can be edited to change:
• the depth of water cells
• the shore type of coastal cells.

From the data tool bar, select the cell classification that you wish to view.

You may choose:
• Cells
• Depths

Editing cannot be used to increase or decrease the area covered by the grid or the number of
grid cells. To change either of these parameters requires creating a new grid.
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1. Select Edit Land-Water Grid Cell from the Data menu, or click on the Edit Grid Cell
icon on the tool bar.

2. It is often helpful to zoom in on the area being edited.

3. Click in any cell of the grid. Hold down the CTRL key to select multiple grid cells.

4. Use the cell edit window to edit the characteristics of the cell.
Click Apply to apply the new type to the cell(s). If more than one cell is selected, then
Apply will alter the characteristics of all the selected cells.

5. If a water cell is selected, then you may also edit the depth of the cell.

6. Once all editing is complete, select Save Scenario under the File menu. You will be
prompted to save your changes to the grid.

Current data is required to run a spill simulation; the model will not run without a current field.
Current data is provided and is based on the data in the COZOIL database. However, the
COZOIL database lacked information such as phase (ie. when is high tide) and direction. So,
current fields were generated based on the current speed stored at each shore segment. A
vector was generated and assumed to be parallel to the shoreline. This data has no phase
information and has artificial direction information. Tidal period was also obtained from the
COZOIL database and the system will suggest which tidal period to use based on the location
of the spill site and the tidal period in that region.

A current sketching tool is provided so that these currents may be edited manually.
These currents can then be spread over the area of interest to create a rough estimate of the
current field. The current painting capability is designed as a temporary measure to
pictorially represent general current features. It does not replace hydrodynamic model
output, and can lead to the description of flow patterns which are clearly not mass
conserving.

The name of the current file that is loaded with the active scenario is shown on the data tool
bar.

Types of Currents

The COZOIL currents have two components:
• M2 tidal currents (two high tides a day, period approximately 12.4 hours)
• K1 tidal currents (one high tide a day, period approximately 23.9 hours)

Tidal currents are time-varying currents caused by the ebb and flood of the tide. The vectors
that are entered are assumed to be max flood stage. By setting the time of high tide in the spill
form, the model will initialize at different times in the tidal cycle. However, the COZOIL database
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does not have current direction so direction of high tide is not known. So, setting the high tide
time will affect the point in the tidal cycle that the simulation begins, but it is artificial as we do
not know the true direction of maximum flood (only assumed) and no phase information is
available.

Viewing Current Data

The current vectors in any currents file can be displayed. To display a current field it must be
specified as part of the active scenario. Use Edit Scenario in the File menu to change the
selected current file for the active scenario.

Current Grid

Display Vectors Display Current ScaleComponent

• To specify the current component to be viewed, select from the list of current types. Check
the display box to the very left on to view the current vectors on the map. Use the Play
buttons to animate/step the current vectors in time. The time label will give the time in hours
into the animation.

• To display the current grid, check the grid icon to the right of the tool bar on.

• Click the Scale icon to bring up the Scale Window

This window may be used to scale the presentation
of the current vectors on the map.
It does not change the actual current values.

To scale the size of the displayed current vectors, click on the up/down arrows at the bottom of
the window to increase/decrease the vector size. The vector to the left of the up/down arrows
shows the size that a current vector will be displayed on the map. The velocity of this vector is
shown at the bottom right of the window. Its units depend on the Vector Units setting under the
Display Settings option of the File menu. Once the representative arrow is of the desired size,
click on Apply to change the display scale of the currents on the base map. This does not
change the value of the data, only its representation.

Editing a Currents Grid

Any existing grid can be edited to change the designation of individual cells as land or water.
Editing cannot be used to increase or decrease the area covered by the grid or the number of
grid cells. To change either of these parameters requires creating a new grid.

To edit a currents grid it must be specified as part of the active scenario and it must be
displayed.

With the desired grid displayed:

3-5
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1. Select Edit Current Grid Cell from the Data menu.

,.:.>.~,;i';,:",">

~reate Grid ~
Edit Land-Water Grid Cell
Current :'!lector ~
Edit Current Grid ~ell

Enter/Edit Winds

Oil DataBase

2. Click in any cell of the grid to toggle its designation from water to land or from land to
water. Continue to toggle grid cells until the grid has been adjusted to your satisfaction.

3. Once all editing is complete, select Save Scenario under the File menu. You will be
prompted to save your changes to the grid.

Adding/Editing Current Vectors

Currents are entered into the currents grid as vectors, which are displayed as arrows whose
length represents the speed of the current. The vectors point in the direction the current is
moving.

To add current vectors to a currents grid follow the steps below:

1. Select the type of current to be added (M2 or K1).

2. It is often helpful to zoom in on the currents grid or some portion of the grid before
entering current.

3. Select Current Vector from the Data menu, then select Add Current Vector; or click
on the Add Current Vector icon on the toolbar.

4. Tidal currents are specified at maximum flood. The tide is assumed to be rectilinear,
i.e., ebb tide is the opposite of flood tide.

5. Position the cross-hair cursor in any grid cell to anchor the current vector in that cell.
Depress the mouse button and drag the cursor away from the anchor point to draw a
vector defining the current speed and direction. The speed and direction (in degrees
clockwise from North) of the vector are displayed at the bottom left of the map window.
Release the mouse button to set the end of the vector when the desired speed and
direction are displayed.

Note that as the mouse is moved over current grid cells, the value for the current
vector in that cell will be displayed in the status section at the bottom of the
screen.

3-6
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6. To edit an existing vector, click on the existing vector position and draw in a new vector.
This will replace the previous vector. Note that as you move the mouse over grid cells
that contain vectors, the exact speed and direction of each vector is displayed in the
status bar on the bottom of the screen.

A right-click on any current grid cell will allow entry of the current vector values
exactly. This allows the user to enter exact values for specific cells.

7. Repeat steps 5 & 6 to enter as much data as you have available. Optimally the data will
establish the basic flow pattern.

When done, save your changes. Select Save Scenario from the File menu to save changes.

If the grid is only partially filled with currents and not suitable for use by the spill model, the final
step is to fill the empty grid cells based on the vectors just entered. See Filling the Current
Field section.

Filling the Current Field

Two utilities are provided to fill the current field with the user-input current vectors. The
Spread option interpolates/extrapolates your input currents to empty cells; the Smooth option
spatially smooths the differences between the current vectors. Additionally, the Smooth
operation constrains the flow so that no flow occurs across a closed boundary (Le., land).
Thus, after smoothing, a current grid cell with two closed boundaries will not have any
associated current.

The Spread option should always be selected to fill empty cells. It should be done first. The
Smooth option is generally done once to create a more uniform current field.

It is often helpful to display your input currents and the Spread/Smooth currents in different
colors. Use Display Options in the File menu to change the vector colors .•
To Spread current vectors over a grid:

1. Select Current Vector from the Data menu, then select Spread Vectors.

2. The user-defined vectors will be used to interpolate/extrapolate current vectors into
empty grid cells.

To Smooth current vectors in a grid:

1. Select Current Vector from the Data menu, then select Smooth Vectors.

2. To smooth only the interpolated/extrapolated vectors and leave the user-defined vectors
unchanged, select Only Interpolated Vectors. To smooth all the current vectors in the
grid, select All Vectors.
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When done, select Save Scenario from the File menu. You will be prompted to save the
changes. The completed grid contains background and/or tidal currents saved in a file with a
DIR extension. This file can now be used in a spill simulation.

Currents Display Options

• To change the units speed. Select Display Settings from the File menu. Click on
the units box to the right of Vector Units to toggle through the options available.

• To change the color of your input current vectors. Select Display Settings from the
File menu. Click on the color box to the right of User Defined Vector Color and
select the desired color.

Scaling Current Data

Once a current field has been entered, the magnitude of all the current vectors in the field can
be increased or decreased by a constant scale factor.

To scale a current field it must be specified as part of the active scenario and the current
component to be scaled must be selected.

From the Data menu select Current Vector and then
Scale Vectors. In the Vector Scaling window, enter the
scaling factor to be applied to all current vectors. For
example, a factor of 1.20 will increase the magnitude of
all current vectors in the selected current component by
20%. To decrease the magnitude of the vectors, enter a
number less than 1.0.

The wind data required for a model simulation consists of a series of wind speeds and
directions covering the time period being modeled. COZOIL contains a Wind Data Editor to
facilitate the task of entering wind data.

Alternatively, the user may select Climatological Wind to run the model with and a wind time
series will be generated automatically based on the average wind speed for the month of the
spill in that region. The system will find the COZOIL shore segment nearest to the spill site to
get the average wind speed and standard deviation and use a Poisson distribution to create a
wind time series.

The Wind Data Editor

The Wind Data Editor contains tools to input and display wind data. A "dart board" is used to
input wind speed and direction with a simple "point and click" technique. Alternately speed and
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direction can be manually entered. A time increment setting is available so that wind data do
not need to be input at hourly intervals. To view the data in the wind file a listing of each wind
speed and direction entered is provided, and a stick plot showing the wind data is presented.

11/22/96 03 AM
11/22196 04 AM
11/22196 05 AM
11/22196 06 AM
11/22196 07 AM
11/22196 08 AM
11/22196 09 AM
11/2219610 AM
11/2219611 AM
11/2219612 PM
11/22196 01 PM
11/22196 02 PM

1
11/22196 05 PM
11/22196 06 PM
11/22196 07 PM
11/22196 08 PM
11/22196 09 PM
11/2219610 PM

The dart board is the quickest way to enter wind data. The rings of the dart board correspond
to different wind speeds (in knots), increasing in speed away from the center. The direction
from which the wind is blowing is indicated by the clockwise angle (0 to 360 degrees) around
the rings of the dart board. As you move the mouse around the dart board, the wind speed and
direction corresponding to the mouse's position are displayed in the text box above the dart
board. Clicking the mouse on the dart board adds a wind record to the wind file.

The wind data you enter is assumed to follow the meteorological convention: the direction is
the direction FROM WHICH the wind is blowing. The stick plot which displays the wind data
follows the oceanographic convention: the direction is the direction TOWARD WHICH the wind
is blowing.

Entering Wind Data

The following steps describe the process of creating a new wind file.

1. Start the Wind Data Editor by selecting Enter/Edit Winds from the Data menu.
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2. Select New File from the Wind Data
Editor's File menu. Enter a name for
the wind file and set the start date and
time for the new file. Clicking in the
box for the date/time entry brings up a
calendar from which the date and time
can be selected. The default
coordinates for the wind station will be
the center of the map.

To use the calendar click on the
desired year, month and day of month
on the calendar display. To select the
current day's date, click on the Today
button located below the monthly
calendar. Use the up/down arrows to
the right of the hour and minute boxes at the bottom of the calendar to select the time
the wind record is to begin. Click on OK to save the selected date/time and return to the
New Wind File window.

3. Set the time Increment (in hours) at which data will be entered. At the lower right of the
Wind Data Editor window is the Increment box with up/down arrows to
increase/decrease the increment. The time increment is the duration that each wind
speed/direction entry will last. For example, a 6 means that each wind observation is
valid for the next six hours. At any point while entering wind data, the time increment
can be changed. Therefore you can enter known hourly wind data (Increment equals 1)
for a period of time.

4. Enter wind speed and direction records by
either clicking on the dart board, or selecting
the Add Record button. This will allow
manual entry of wind values

To use the dart board, place the mouse on
the dart board at the desired wind speed and
direction, and click. Each click of the mouse
on the dart board generates one entry in the
time series. The wind data entry is added to
the table to the left of the dart board and to
the stick plot graph at the lower left of the
Wind Data Editor window.

5. When all data have been entered, select Save File from the File menu to save the file.
The table and the stick plot will clear.

6. Exit the Wind Data Editor by selecting Exit from the File menu.
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Editing Wind Data

The following steps describe the process of changing an existing wind file. Existing wind data
entries in the file can be changed and new wind records can be added to the end of the file.

1. Start the Wind Data Editor by selecting Enter/Edit Winds from the Data menu.

2. Select Open File from the Wind Data Editor's File menu. Select the name of the wind
file to be edited. Click OK to continue.

3. To change existing wind data entries:

• Scroll through the wind record listing to the date and time for which wind data will be
changed. Click on the data entry to be changed (it will be highlighted).

• To use the dart board to change the wind speed and direction, place the mouse on the
dart board at the desired wind speed and direction, and click. The speed and direction
corresponding to the mouse's position are shown in the text box below the dart board.

• To change data by typing the speed and direction, double click on the entry to be edited
(or highlight the entry and select Edit Record).

4. To add more wind data to an existing wind record:
• Scroll to the end of the wind record listing.
• Add wind records by clicking on the dartboard or by using the Add Record button.

5. When all changes have been made, select Save File from the File menu to save the
file. The table and the stick plot will clear.

6. Exit the Wind Data Editor by selecting Exit from the File menu.

Importing Wind Data

A wind data file can be created in the ASW format (see Appendix) using a text editor and
imported into COZOIL for use in the spill models.

To import an ASW wind file:

1. From the Data menu select Enter/Edit Winds.

2. From the File menu of the Wind Data Editor select Import ASW File.

3. Select the file to be imported.
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COZOIL contains a library defining the characteristics of several types of oil. The standard oils
are:

gasoline
diesel
light crude oil
medium crude oil
Prudhoe Bay crude
heavy crude oil
Bunker C (fuel oil #6)
JP-4 (fuel oil #1)

The parameters stored in the oil database affect the spreading, evaporation, and mousse
formation algorithms of the COZOIL fates routines during spill simulations.

Any of the parameters can be changed. New oils may also be added to the database. Oil data
are stored by geographic location, so any changes made to the oil database are specific to the
oil database in the geographic location active when making the changes.

Oil Characteristics

The oil database contains a name and eight parameters identifying each oil. The oil
parameters are used by the spill models to characterize each oil's behavior. Each type of data
in the oil database is described below.

Oil Name - a unique name up to 20 characters long to identify the oil.

Density - the density of the whole, unweathered oil (qrn/cm").

Viscosity - the dynamic viscosity of the oil at 25°C (cP).

Interfacial Tension - the oil-water interfacial tension (dyne/em).

Maximum Water Content - the maximum water content of emulsified oil (%). Enter 0 if the oil
does not emulsify.

The final four parameters are used to define the evaporation characteristics of the oil. These
parameters are inputs for Mackay's evaporative exposure approach used to model evaporation.
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Initial Boiling Point and Gradient of Curve -
Determine these values for the oil by plotting
the oil's liquid (not vapor) temperature in
degrees Kelvin versus the fraction of oil
condensed (the modified distillation curve). If
only the vapor temperature is available for the
distillation curve, a rough approximation of the
liquid temperature can be obtained by adding
30° C to each vapor temperature. Enter the
initial boiling temperature (degrees K) for the
first parameter and the slope of the distillation
curve for the second parameter.

Evaporation Constants A and B - These values are determined by plotting In(H)
versus TBfT. The relationship between Hand TB is

In(H) = A - B * ( TBIT)

where

H = Henry's Law constant
TB= Boiling temperature (K)
T = Ambient temperature (K).

Values of A = 6.3 and B = 10.3 generally provide reasonable results for most oils.

Editing an Oil

The name and parameters defining any oil already in the database can be changed. The
parameters are described in the previous section Oil Characteristics.

To edit an oil:

1. Select Oil DataBase from the Data menu.

2. Click in the first field of the Oil Database window to display the list of available oils.
Select the oil to be edited.

3. Click on the field containing the property to be changed. Any of the parameters,
including the oil name, can be changed. Enter the desired value. TAB or click to move
to a new field.

4. Repeat step 3 to change all desired properties.

5. To save changes and exit the Oil Database window, either click OK at the top of the
window or press the ENTER key after entering data in a field. To exit without saving
changes, click on Cancel at the top of the window.
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Adding an Oil

To add a new oil to the database you must specify the parameters defining the oil's
characteristics. Default values are provided based on the previous oil listed. The oil
parameters are described in the section Oil Characteristics.

To add a new oil:

1. Select Oil DataBase
from the Data menu.

2. Click on New Oil at the
top of the Oil Database
window. This will fill the
fields Oil Database and
Oil Name with the name
"New Oil". The other
fields will contain the
values for the oil which
was listed when New
Oil was selected.

Click in the Oil Name
field and replace the
name "New Oil" with the
name of the new oil to
be entered. No check is
performed to verify that
this name is different
from other names in the oil database. Therefore, unless you mean to have two oils with
the same name, be certain to enter a unique name.

4. Move to each of the fields containing the values to be changed. Enter the desired value
TAB or click to move to a new field.

5. Repeat step 4 to change all desired properties.

To save changes and exit the Oil Database window, either click OK at the top of the
window or press the ENTER key after entering data in a field. When you save the
changes, the name in the Oil Name field is added to the list of oils in the Oil Database.
To exit without saving changes, click on Cancel at the top of the window.
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4. Running the Oil Spill Model
The COZOIL trajectory and fates model tracks the surface movement of oil and determines
the oil's distribution in various environmental compartments: water surface, atmosphere, water
column, and shoreline. The model has specific focus on the oil-shoreline interaction and
algorithms are included that combine oil information, shore type, wind speed/direction, and tidal
information to provide analysis on how the oil interacts with the shoreline.

There are a number of simple steps to running a new spill simulation.

1. From the File menu, select the New Scenario, type the scenario name.

2. From the Model menu, select the spill site on the map.

3. From the Model menu, select the Run Model option.

4. Fill in all the appropriate values on the spill form tab windows (see Specifying the Input
Data section for more details). Be sure to select a land-water grid, current grid, and wind
file. See the Specifying Environmental Data chapter for information on how to create
these files.

5. Click the Run Model button and let the model run the simulation. The Simulation
Complete message box will let you know that the model is complete.

6. Use the tools on the top toolbar to view the results.

The input data required by the spill trajectory model includes a land-water grid, a wind time
series, a current field, and a spill scenario that describes the conditions of the spill. The first
three of these types of input and the steps involved in specifying the files are described in detail
in Chapter 3. Specifying the spill conditions is described below.

The spill scenario is the information that uniquely describes the conditions of the spill
simulation. Included in the spill scenario are such data as the spill location, amount and type of
oil spilled, environmental conditions, and various model parameters.

Two steps are involved to specify the spill scenario. The first locates the spill site, and the
second specifies the rest of the scenario information.

To set the spill location:

1. From the Model menu, choose Select Spill Site.

2. Position the mouse cursor on the map over the spill site. The coordinates of the cursor
are displayed in degrees at the lower right of the map window, and change as the cursor
is moved about the map. Click when the mouse is positioned on the site of the spill.
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To specify the spill scenario:

From the Model menu, choose Run Trajectory Model.

Set the scenario name at the top right of the window, or select an existing scenario to fill the
form with the values used for that scenario. Specify a new name if you don't want to replace
the existing scenario with the new simulation.

The Trajectory Model window contains three tabs: one each to specify scenario information,
environmental data, and model parameters. Both the scenario information and environmental
data tabs must be filled out to completely specify the spill scenario. The model parameters tab
controls certain model variables for the simulation, but does not specify spill specific
information. The fields in each tab are described below.

Once the necessary input data has been specified and the spill scenario has been defined, the
model can be run. While still in the Trajectory Model window, click on the Run Model button at
the top of the Spill Information form.

A separate process with its own window will display a tabular output of the oil mass distribution
in the environment as the simulation proceeds. When the simulation is complete, view the
model output as described further in this chapter.

Scenario Information:

Description - an optional description of the scenario.

Latitude. Longitude - the spill location. These coordinates correspond to the spill site selected
using the mouse, and can be adjusted here. To the right is the option to specify the latitude
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and longitude in decimal degrees (00.00), degrees and decimal minutes (DO MM.MM), or
degrees-minutes-seconds (DO MM SS).

Spill Start Time - the date and time the spill starts. Click in the field to bring up a calendar on
which to specify the date and time. To use the calendar click on the desired year, month and
day of month on the calendar display. To select the current day's date, click on the Today
button located below the monthly calendar. Click on OK to save the selected date/time and
return to the Trajectory Model window.

Oil Spill Amount - is followed by three fields to specify the amount spilled, the units of the
amount spilled, and the type of oil spilled, respectively.

Spill Duration - the length of time (hours) that oil is being released at the spill site. An
instantaneous spill (all oil released at once) has a spill duration of O.

Model Duration - the length of the spill simulation (hours), i.e. how long the model will make a
prediction for.

Number of Stochastic Runs -If this is specified as more than 1, the COZOIL will run in
stochastic mode and, based on randomizing climatological wind information, will produce a
probability table of where the oil will impact land.

Environmental Data

Air Temperature/Water Temperature - average air/water temperature over the length of the
simulation. This is retrieved from the COZOIL database.

Grid File - specifies the land-water grid to be used in the simulation.

Wind File - the wind data file to be used in the simulation. The list includes the
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names of all available wind files, and the beginning and ending times of each wind record.
To run the simulation with climatological wind, toggle the Use Climatological Wind option.
To run the simulation (stochastic only) with a markov matrix, toggle the Markov Matrix option.
Click the Wind File button to access the Wind Data Editor to edit or create wind files.

Current File - specifies the currents to be used in the simulation. Next select the current
components (tidal and/or background) to be used in the simulation. The default value will
automatically be set by finding the tidal period for the region of the spill. The database is
searched to find the shoreline reach nearest to the spill and the period is used from that reach.

Remember that COZOIL tidal currents have vectors for maximum flood stage. The time of
high tide entered here allows the model to phase these currents for the oil spill
calculations. Time of high tide is the time when the water elevation is the maximum.

Tide range may manually be entered. The default value is retrieved from the COZOIL
Database. The database is searched to find the shoreline reach nearest to the spill and the
range is used from that reach.

Model Parameters:

Model Time Step - the time step for model calculations (minutes).

Output Time Interval - the time interval at which model calculations are saved (minutes). It
should be a multiple of the model time step.

Horizontal Diffusion - controls the random horizontal component of the oil's movement (m2/s).

Number of Particles - the number of individual spillets used to represent surface oil.

4-4



n
o
Q

n
Q

~

n
o
n
n
n
n
D

~ n
n
n
n
r

Wind Factor - the wind drift factor (%).

Note: The animation sequence will be re-displayed to the currently selected output
time when the map is redrawn. To turn off the animation, click on the Rewind
button to set the simulation to the very beginning.

Wind Angle - the angle oil moves relative to the wind (degrees).

Spreading Coefficient - controls the rate of surface slick spreading (lsec).

Mousse Coefficient - controls the rate of emulsification.

Minimum Thickness - controls the minimum thickness to which oil can spread (mm).

Run RCPWAVE - Run the model with/without wave calculations. (see technical manual)

Entrainment Algorithm - Select which entrainment algorithm to use. (see technical manual)

Once a model simulation is complete, the spill trajectory can be viewed at any time as an
animation sequence. The output from a model simulation is saved as part of a scenario. The
name of the active scenario is displayed on the toolbar.

If the scenario was run with the Number of Simulations greater than 1,
the model was run in stochastic mode and animations are not available.

Select the scenario to be displayed. The name of the active scenario is shown at the center of
the top toolbar. To select a different scenario for display, use Open Scenario under the File
menu to open an existing scenario. The five buttons to the right of the scenario name on the
toolbar control the display of the spill animation. Use the buttons on the toolbar to start, stop
and rewind the animation.

Rewind the animation to the start of the simulation.

Display the animation in reverse.

Step through the animation, one time step at a time.

Stop the animation sequence.

II Run the animation sequence.

The simulation date and time corresponding to the animated
trajectory display are given at the right side of the toolbar. As the spill

animation progresses, the date and time are updated accordingly. To display a particular time
during the simulation, select from list of available simulation times.

4-5



f1
Q

n
n
Q

Q
C'"

n
n
n
D
n
n
n

en
Q
n
n
n

e'1I .

From the main menu, use the Oil spill
Display Settings window to set the oil
spill colors and display options for
trajectory animations.
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Fates Listing will create an ASCII file of the fates information.
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Fates Graph will display a window with a graph showing the mass of oil on the water surface,
in the atmosphere (evaporated), in the water column (dispersed), and on the shoreline. The x-
axis of the graph is the time into the simulation; the y-axis is the oil mass %.
Double clicking, or right-clicking, on this graph brings up customization options for the graph
presentation, printing, and data export options.
This data is stored in a dBase file in the FATES directory under the location and may be
important to other applications such as Access or Excel for further analysis.

Oil-Shore Output provides a summary listing of the shoreline impacts.

The trajectory model output file is written in a standard dBase file format for use by other
applications. This data is stored in a dBase file in the TRAJ directory under the location with a
filename of scenario. DBF. It may be used by other applications such as Access or Excel for
further analysis.

A listing of this file is available under the Trajectory Table option of the Model menu. The file
includes data for each spillet at every output interval. The data given in the file are:

• Time - time into the simulation (hours).
• DateTime - the calendar date (month/day/year) and hour (24-hour time).
• ParticlelD - an identifying number for the spillet. This number is not necessarily a

unique identifier because when spillets combine with other spillets, go totally ashore, or
move outside the model grid, their ID number can be re-used and the particle ID array is
compressed.

• Longitude - the spillet longitude location (decimal degrees). A negative value is used to
denote west longitude.

• Latitude - the spillet latitude location (decimal degrees). A negative value is used to
denote south latitude.

• Oil Mass - spillet mass (metric tons).
• Thickness - spillet thickness (meters).
• Radius - spillet radius (meters).
• Viscosity - spillet dynamic viscosity (centiPoise).
• Status - a code indicating the status of the spillet (0 = ashore, 1 = water surface, 2 = in

ice (not used), 3 = outside model grid).

mpact Probab

When a scenario is selected that was run in stochastic mode, then this toolbar will be available
instead of the animation controls. Select the check box and select either Impact Probability or
Amount Ashore to display the color coded probability grid on the map.
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A text listing of the stochastic output is also available under the Model menu.
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be clicked on to obtain
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5. COZOIL Tools

To delete unwanted files
created by COZOIL, select
File Maintenance from the
Tools menu. This brings up
the File Maintenance window.
Select the type of file to be
deleted and all existing files of
that type will be listed. From
the list select the file to be
deleted and then click on the
Delete File button. You will
be asked to verify that you
really want to delete the
selected file.

To edit a color key, double-click on one of the color key
divisions and the Legend editor will activate.
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The Legend Editor allows the user to
edit the:

• titles
• each division's name and color.

Click New Division to add a new
division. Double-click on an existing
division to delete the division.

You may open existing and save color
combinations with the Open Color File
and Save Color File buttons.
The Auto button may also be used to
create a new color combination.

If the legend contains number ranges,
(Le., 0;2 2;4), then the Auto Division
button allows you to set the first number
and the very last number and create an
even set of ranges between these two
numbers.
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6. The COZOIL Database

The COZOIL interface and model use the COZOIL database extensively to obtain
environmental conditions for the region of the spill in the appropriate time of year. This contract
did not edit or change the original COZOIL database in any way.

The directory structure for each location (Arctic, Bering, Goa) in COZOIL is as follows:

Coast
• Currents
• Fates
.Gis
• Grids
• Icons
• Keys

·.Oil
.Outdata
• Rundata
• Trai
• Winds
~ Location. ini

File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder
File Folder

1KB Configuration Settings

The COZOIL database files reside in the Coast directory and are:

Arc_def.del
Arc_fech.txt
Arcjaqn.del
Arc_shor.del
Arc_temp.del
Arc_tide.del
Arc_type.del
Arc_wind.del

(Replace Arc_ with Goa_ for Gulf of Alaska and Ber_ for the Bering Sea.)
Exact descriptions of these files may be obtained by reviewing the original COZOIL
documentation. The way this information is used is summarized below.

Coastline
The Arc_shor.del file contains the segments and sub-segments for the location. These data are
in ASCII format and are not polygonized. ASA used Arclnfo to process these data so that land
polygons may be represented on the map. The Arc_shor file is loaded at initialization and the
segments may be plotted on the map and color coded by shoreline type. Note that the
resolution of the data is less than satisfactory in certain areas.

Shoreline Characterization
Similar to the original COZOIL, a grid system is used to characterize land/water, shoreline type,
and depth. The original COZOIL created a 25x25 grid "on-the fly"; COZOIL 97 uses a
predetermined grid that automatically interpolates shore types and depths from the Arc_shor
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file. Shoreline cells are assigned the type of the nearest coastal segment in the COZOIL
database. Characteristics are used for each shoreline type based on the COZOIL values.

The grid may be up to 250x250 cells and the interface allows the user to create, review, and edit
grids for use by the model. Islands are easily incorporated in the grid. The format of this grid is
the ArcView grid export format (HDRIFL T format). This allows gri~s to also be created and
edited within ArcView.

Depths
Using the distance offshore values for 1m, 10m, and 20m, the grid creation process determines
the depths of the water cells in the grid. Cells beyond the 20 m bathymetry contour are given the
default depth value specified by the user.

Tidal Range
Tidal range is automatically retrieved from the Arc_tide.del file. The database is searched to find
the shoreline reach nearest to the spill site and the range is used from that reach. The user may
override this value in the model input form.

Currents
The Arc_tide.del file contains tidal current velocity, amplitude and period for each segment.
Similar to the original COZOIL, a current grid was created and values for coastal cells (water
cells beside land) were obtained from the database. However, the COZOIL database lacks
information such as phase (timing of high tide) and direction. Therefore current fields were
generated based on the current speed stored for each shore segment. A vector was generated
and assumed to be parallel to the shoreline (following the original COZOIL). These data have
no phase information and have artificial direction information. Tidal period was also
obtained from the COZOIL database and the COZOIL interface suggests which tidal period to
use based on the location of the spill site and the tidal period in that region.
The coastal cell current values were interpolated over the entire grid field. However, there is no
offshore current information and these data are not reliable.

Winds
The use has two options for wind data:
o Create a wind time series manually,
o Use climatological mean wind speed and direction from the database to generate a wind

time series statistically.

The database is searched to find the shoreline reach nearest to the spill and the wind values
(mean wind speed and direction, and standard deviation of the wind direction from
Arc_wind.del) are used from that reach for the month of the spill.

Air Temperature and Water Temperature
The database is searched to find the shoreline reach nearest to the spill and the temperature
values (from Arc_temp.del) are used from that reach for the month of the spill. The user may
override these values.

Wind Fetch
The database is searched to find the shoreline reach nearest to the spill and the wind fetch
values (from Arc_temp.del) are used from that reach for the month of the spill.

Input File
The COZOIL interface creates an input file called "Scenario".INP in the RUNDATA directory
under the location directory. This file contains the input parameters for the spill.
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An example listing is:

[COZOll]
Scenario=test1
Description=description
Spill lon=-154.068336011 064
Spill lat=59.1785182315071
Start Year=97
Start Month=4
Start Day=30
Start Hour=10
Start Minute=O
Release Duration=6
Amount Spilled=1 0000
Simulation length=24
Number Of Wind Files=1
Climatological Wind=O
Current File=GOA.DIR
Current Components=1
High Tide=6
High Tide Minute=O
Tide Range=4.42
Grid File=SAMPlE.Fl T
Oil Name=MEDIUM CRUDE all
Oil Units=5
Air Temp=2
Water Temp=4
Ideltat=60
ouUntvl=60
ddxy=3
nsp_rls=100
wspil_min=10
wndfactor=3.5
wndangle=O
C_spread=150
thkmin=.0001
c2_mousse=.000002
Nsims=1
Make DBF=-1
Nearest Segment=50.071
Fetch 1=1 0.41
Fetch2=72.66
Fetch3= 128 .38
Fetch4=0
Fetch5=0
Fetch6=0
Fetch7=0
Fetch8=.89
Wind Speed=1.29
Wind Direction=145
Wind Standard Deviation=85
Windfile1 =ZERO _WND.WNE
Wnd1Ion=-158.522170509435
Wnd 11at=57.6442738233146
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.ASW Import Wind File Format

station latitude
N orS
station longitude
EorW
description of data
year, month, day, hour
wind record start
year, month, day, hour
wind record ends
station height, units

(decimal degrees)
(is latitude North or South)
(decimal degrees)
(is longitude East or West)
(optional, can be blank)
(leave a space between each)

(leave a space between each)

(height at which measurements
made, in meters and units of

wind file, supports KNOTS & MIS)
year, month, day, hour, direction, speed
• (Direction, 0'_360',

Speed in m/sec)
•
•
•
end

Example

53.4144134521484
N
5.50178252160549E-03

W
DEMONST.WNE
96 3 9 7
96 3 11 15
10 KNOTS
96 3 9 7 22 15
96 3 9 8 22 15
96 3 9 9 68 15
96 3 9 10 68 15
96 3 9 11 112 15
96 3 9 12 112 15

Real *4
Character *1
Real *4
Character *1
Character *80
Integer *2

Integer *2

Integer *2, character

Integer *2
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SHRCHAR3.DAT Shoreline Characteristics File Format
(in COlOIL\location\COAST directory)

ASCII file

Line Variable Comments Variable type

1 Shoretype name e.g., marsh, rocky shore Character *20

2 Maximum oil thickness (mm) 3 values, leave a space Real*4
on beach for oil with kinematic between each
viscosity = 0-30,30-2000,
>2000 cSt

3 Foreshore length(m), 4 values, leave a space Real *4
foreshore angle, backshore between each
length (m), backshore angle

4 Fraction of oil partitioned to 5 values, leave a space Real *4
groundwater, specific yield of between each
sediment, porosity of
sediment, so- percentile
grainsize (m), fractional
organic carbon content of
sediment

Repeat these four lines for each shoreline type.

Example

EXPOSED ROCKY SHORE
0.5 2.0 2.0
35 14.0 15 16.9
O. .9 .00001 .000001 .001
GRAVEL/COBBLE/BOULDER
2.0 9.0 15.0
40 6.3 15 5.8
.05 .14 .16 .16 .001
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.WAV Offshore Wave Input File Format
(in CQZQIL\location\CURRENTS directory)

Unformatted sequential access file

Line Variable Comments Variable type

1 Wave_tide True if file contains tide Logical*1
height, False otherwise

2 Wave height (m), wave period 4 [or 5] values Real*4
(sec), wave direction (from
North), wave duration (hrs),
[tide height (m)] ,

n
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Repeat line 2 for duration of wave record to span length of simulation.
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.MKV Markov Matrix File Format
(in COZOIL\location\WINDS directory)

ASCII file

Line Variable Comments Variable type

1 First day and last day of year for which 3 values, leave a Integer
data are valid, hourly interval of original space between each
data from which matrix derived

2 Maximum wind speed (m/s) in each of 5 5 values, leave a Real*4
speed bins space between each

3 Probability that next wind vector will be 41 values, leave a Real *4
from state J, given that present vector is space between each
from state I (I = row number = present
wind state, J = column number =
subsequent state) ..

Repeat line 3 for each direction/speed bin (for a total of 41 times). See the orlqinal COZOIL User's
Manual (Reed et aI., 1988) for a complete description of how a Markov matrix is generated.

Example

1 366 1
2.00 4.00 6.00 8.00 15.00

.1538 .1538 .0000 .0000 .0000 .0769 .0769 .0000 .0000 IThe first row of the matrix. The 41

.0000 .0000 .0000 .0000 .0000 .0000 .0000 .0769 .0000 Ivalues are the probabilities of the

.0000 .0000 .0000 .0769 .0000 .0000 .0000 .0000 .0000 Isubsequent wind speed/direction

.0000 .0000 .0000 .0000 .0000 .0000 .0000 .0000 .0769 I for wind currently from the North

.0769 .0000 .0000 .0000 .2308 I in the first « 2 m/s) speed bin .

.0138 .3825 .0968 .0092 .0000 .0092 .1659 .0507 .0000 I The second row of the matrix .

.0000 .0000 .0276 .0184 .0046 .0000 .0000 .0138 .0092

.0000 .0000 .0000 .0046 .0000 .0000 .0000 .0000 .0046

.0046 .0000 .0000 .0000 .0046 .0000 .0000 .0000 .0092

.1060 .0230 .0000 .0000 .0415

.0000 .1203 .4023 .0902 .0113 .0038 .0376 .0902 .0226 IThe third row of the matrix .

.0000 .0000 .0000 .0038 .0000 .0000 .0000 .0000 .0000

.0000 .0000 .0000 .0000 .0000 .0000 .0000 .0000 .0000

.0000 .0000 .0000 .0000 .0075 .0000 .0000 .0000 .0000

.0526 .1165 .0414 .0000 .0000



Line Variable Comments Variable type

1 File record length, 6 values. Integer*2 (all)

Number of records in file Minimum file record
(including header), length is 12.

Number of cells in E-W direction
in currents grid,

Number of cells in N-S direction
in currents grid,

Sequence number,

Number of u,v velocity pairs in
record (NVREC)

2 Currents grid cell size in E-W In degrees longitude Real*4 (all)
direction,

Currents grid cell size in N-S In degrees latitude
direction,

Currents grid cell origin in E-W In degrees longitude
direction

3 Currents grid cell origin in N-S In degrees latitude Real*4
direction,

Number of tidal constituents, In degrees latitude Integer*2

Tidal constituent name 1, 2, 3* Character*2 (all)
3 possible values

4 Tidal constituent name 6 possible values Character*2 (all)
4,5,6,7,8,9*

1 for each non- Background current name Character*10
tidal component

1 for each grid Sequence number, Integer*2 (all)
cell with current Grid cell number in E-W

data direction (I),

Grid cell number in N-S
direction (J),

Grid cell flag (1=water),

Currents in grid cell as U,V
pairs (in cm/sec) with tidal
components first in list
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.DIR Currents Input File Format
(in CQZQIL\location\CURRENTS directory)

Unformatted direct access file

"Tidal constituent name must be one of the following 2-character names:
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M2, 52, K1, 01, N2, P1, K2, 01, MF .

The following lines of code are used to read the .DIR file:

READ(NCHYDR,REC=1) NRECL,NDMAX,IMAXC,JMAXC,NSEQ,NVREC

READ(NCHYDR,REC=2) DLONC,DLATC,OLONC
READ(NCHYDR,REC=3) OLATC,NTIDE,(CTIDE(N),N=1 ,3)
READ(NCHYDR,REC=4) (CTIDE(N),N=4,NINE)

NONTID = NVREC - NTIDE*2

NDREC = 4

IF (NONTID.GE.1) THEN

DO N=1,NONTID

NDREC = NDREC + 1

READ(NCHYDR,REC=NDREC) CBAK(N)
ENDDO

ENDIF

NDREC = 4 + NONTID ! 4 + NONTID lines of header

DOWHILE (NDREC.L T.NDMAX)

NDREC = NDREC + 1

READ(NCHYDR,REC=NDREC) ISEQO,I,J,IFLGO, (IU(N),IV(N),N=1,NVREC)

ENDDO
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